Jump to content


Photo

Malwarebytes Shutting Down McAfee


  • Please log in to reply
4 replies to this topic

#1 letnes

letnes

    New Member

  • Members
  • Pip
  • 2 posts

Posted 23 August 2010 - 05:21 PM

I have the paid version of Malwarebytes. When the real time scan is on it is causing McAfee Security Center to shutdown. When I turn real time scanning off McAfee stays on.

I am getting the following error in Event Viewer:

A thread in process C:\Program Files\Common Files\McAfee\SystemCore\mcshield.exe took longer than 90000 ms to complete a request.
The process will be terminated. Thread id : 6108 (0x17dc)
Thread address : 0x7C90E514
Thread message :

Build VSCORE.14.2.0.723 / 5400.1158
Object being scanned = \Device\HarddiskVolume2\Program Files\Common Files\McAfee\SystemCore\mfeapfa.dll
by C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe

I could not find the search tool on the forum.

#2 Firefox

Firefox

    Forum Deity

  • Trusted Advisors
  • PipPipPipPipPipPip
  • 10,041 posts
  • Gender:Male
  • Location:USA

Posted 23 August 2010 - 05:22 PM

Please exclude the following files from your antivirus:

Note: If using a software firewall besides the built in Windows Firewall you'll need to exclude them from it as well

For Windows XP:
  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\zlib.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\Documents and Settings\All Users\Application Data\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\System32\drivers\mbamswissarmy.sys
For Windows Vista or Windows 7:
  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\zlib.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\ProgramData\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\System32\drivers\mbamswissarmy.sys
For 64 bit versions of Windows Vista or Windows 7:
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\zlib.dll
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files (x86)\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\ProgramData\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\SysWoW64\drivers\mbamswissarmy.sys
Note: If using a software firewall besides the built in Windows Firewall you'll need to exclude MBAM.EXE from it as well

Note: Once that's done, please make sure that if either of those programs has any sort of web filter, that you add the following as a trusted site:
data-cdn.mbamupdates.com


The FAQ contains examples of setting file exclusions for some known AV products


Please post back and let us know how it went.

post-2065-0-92797800-1392234217.jpg


Dell Precision T7500, Win7 Ultimate 64bit fully updated, McAfee Corp Edition v8.8,
Watchguard Firewall, Intel Xeon E5606CPU, Dual Quad Core Processors, 16GB Ram,
E5606 @ 2.13GHz, Nvidia Quadro NVS420, Raid-1 Dual 1TB Sata 10000 rpm Hard Drives
Dual DVD Burners, IE10, Opera, MBAM, MBSB, MBAE


#3 letnes

letnes

    New Member

  • Members
  • Pip
  • 2 posts

Posted 23 August 2010 - 05:30 PM

I have the paid version of Malwarebytes. When the real time scan is on it is causing McAfee Security Center to shutdown. When I turn real time scanning off McAfee stays on.

I am getting the following error in Event Viewer:

A thread in process C:\Program Files\Common Files\McAfee\SystemCore\mcshield.exe took longer than 90000 ms to complete a request.
The process will be terminated. Thread id : 6108 (0x17dc)
Thread address : 0x7C90E514
Thread message :

Build VSCORE.14.2.0.723 / 5400.1158
Object being scanned = \Device\HarddiskVolume2\Program Files\Common Files\McAfee\SystemCore\mfeapfa.dll
by C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe

I could not find the search tool on the forum.



It seems to me it's Malwarebytes scanning Mcafee that's causing McAfee to crash, not the other way around. So excluding Malwarebytes from McAfee will not stop the problem. Is there a way to exclude McAfee files and folders from being scanned by Malwarebytes?

#4 noknojon

noknojon

    you know why ---

  • Honorary Members
  • PipPipPipPipPipPip
  • 6,090 posts
  • Gender:Male

Posted 23 August 2010 - 06:28 PM

Hi -
You will find that Firefox is 100% correct in what he is saying - We do get conflicts , at times, with McAfee but by allowing McAfee to be bypassed by Malwarebytes the problem will not exist - This is not unusual in any way -
Please read This Item from our FAQ area that relates to McAfee (it may be an earlier version but the same ideas apply) -

Thank You -
Just another private helper .......................... The answer is always 42, or Reboot
If you are waiting for an answer Press F5 ................. you may have one waiting for you ........

#5 daledoc1

daledoc1

    Forum Deity

  • Spam Hunters
  • PipPipPipPipPipPip
  • 11,934 posts
  • Gender:Not Telling

Posted 24 August 2010 - 07:57 AM

What version of McAfee are you running, and is it home user or enterprise?

FWIW, I had no problems with MBAM Pro (active protection) on either my Vista/32 or my Win7/64 systems alongside the OEM, "bundled" 2009 versions of McAfee that came on my Dell systems.
No conflicts, nothing.
Everything worked great, without having to set up any exclusions, etc (though I did confirm in the FW that MBAM exe files had full permissions).
MBAM Pro was configured to load at Windows startup and worked just fine with McAfee 2009.

That said, the 2010 McAfee updates pushed out 2 weeks ago to Dell customers such as myself rendered my computer unbootable, except into basic safe mode.
Not once, but twice.
After >1 week of diagnostics, troubleshooting and other torture, I ended up having to restore the computer to the factory image from the recovery partition (McAfee had corrupted the OS).
So, I cannot say whether the 2010 version of McAfee will run with MBAM, since the first thing I did after restoring the computer was completely, totally, definitively uninstall McAfee.
Given the sordid tales of McAfee current software builds re: installation problems, computer crashes and other serious issues, it would not surprise me if there were conflicts with MBAM.
There is something inherently flawed with their current software, and I will never go back.
Given a choice -- which I didn't have, since McAfee rendered my computer inoperable -- I would find a way to stick with MBAM and to ditch McAfee. ;)

I do hope you get things sorted out!

daledoc1

(I am now running KIS2011, and have just reinstalled MBAM without any glitches...)

Just a home user & forum volunteer
DT1: Win7/Ult/64 SP1; Intel Core i7-3770 @3.4 GHz; 16 GB RAM; NVidia GeForce GT620; IE9; Fx; TB; Cable HSI; MBAM PRO 1.75.0.1300; KIS2014; SAS Free; CCleaner
DT2: Win7 Ult/64 SP1; Intel Core i7-860 @2.8 GHz; 8 GB RAM; ATI Radeon HD 5770; IE 9, Fx; TB; Cable HSI; MBAM PRO 1.75.0.1300; KIS2014; SAS Free; CCleaner.
LT: Win7 Pro/64 SP1; Intel Core i7-3632 cached @3.2 GHz; 16 GB RAM; NVidia GeForce GT640M; IE 10; Fx; TB; WLAN; MBAM PRO 1.75.0.1300; Sophos ES 10.3; SAS Free; CCleaner.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users