Jump to content


Photo
- - - - -

The famous redirect virus


  • This topic is locked This topic is locked
5 replies to this topic

#1 RodneyMcC

RodneyMcC

    New Member

  • Members
  • Pip
  • 2 posts

Posted 07 November 2010 - 11:29 AM

I have been battling this virus now for a month, when on my browser (firefox) any google search result redirects to dodgy sites. I have used many different anti maleware programs with no success, i work as an IT technitian so i am confident with advanced computing, i actually remove viruses on computers in my spare time but this is beyond me i have tried everything i know. It has affected every machine within my house (3 laptops and 1 desktop computer) it is even affecting mobile phones searching on google or any search engine, once i go outside my house and connect to anyone elses network there is no problem. I have proffesional Avast on my computers and use malewarebytes regularly on each to keep them all clean. However this seems to be invisible to all anti malwares. Its driving me crazy i have searched the internet also and there are no fixes i can find. Please help for i have given up hope...

#2 screen317

screen317

    MBAM Sentinel

  • Moderators
  • PipPipPipPipPipPip
  • 19,486 posts
  • Gender:Male
  • Location:New Haven, CT

Posted 08 November 2010 - 02:42 AM

Hi and welcome to Malwarebytes.

Appears as though your router is infected.



1. Very important: First disconnect your computer from the internet.

2. Router Reset: Next you must reset the router to its default configuration. This can be done by inserting something tiny like a paper clip end or pencil tip into a small hole labeled "reset" located on the back of the router. Press and hold down the small button inside until the lights on the front of the router blink off and then on again (usually about 10 seconds).

3. Reset the IP/DNS settings of your interent connection:
  • Go to Start -> Control Panel -> Double click on Network Connections.
  • Right click on your default connection (usually Local Area Connection or Wireless Network Connection) and select Properties.
  • Select the General tab.
  • Double click on Internet Protocol (TCP/IP).
  • Under General tab:
  • Select "Obtain an IP address automatically".
  • Select "Obtain DNS server address automatically".

[*]Click OK twice to save the settings.
[*]Reboot if you had to change any setting.
[/list]4. Flush the DNS cache:
  • Click the Start logo in the bottom left corner of the screen
  • Click on Run
  • In the command window copy/paste the following:

    ipconfig /flushdns
  • Then hit enter.
  • Exit the command window.
5. Reconnect: Once you have followed all the above steps you can reconnect your computer to the internet.
Chris Fistonich
Research Team

Posted Image

Follow us: Twitter, Become a fan: Facebook

#3 RodneyMcC

RodneyMcC

    New Member

  • Members
  • Pip
  • 2 posts

Posted 08 November 2010 - 02:07 PM

Thanks so much this has worked and i am back online with no problems.

#4 screen317

screen317

    MBAM Sentinel

  • Moderators
  • PipPipPipPipPipPip
  • 19,486 posts
  • Gender:Male
  • Location:New Haven, CT

Posted 08 November 2010 - 02:18 PM

Great! :P

Please make sure your router's password is as secure as possible to prevent this in the future.


Anything else I can help you with?
Chris Fistonich
Research Team

Posted Image

Follow us: Twitter, Become a fan: Facebook

#5 TexMurphy01

TexMurphy01

    New Member

  • Members
  • Pip
  • 1 posts

Posted 16 November 2010 - 06:42 PM

I had not suspected my router at all.

This one thread has solved my problem where countless others have failed. You have my thanks.

#6 screen317

screen317

    MBAM Sentinel

  • Moderators
  • PipPipPipPipPipPip
  • 19,486 posts
  • Gender:Male
  • Location:New Haven, CT

Posted 19 November 2010 - 03:57 AM

Glad we could help. :)

If you need this topic reopened, please send a Private Message to any one of the moderating team members. Please include a link to this thread with your request. This applies only to the originator of this thread.

Other members who need assistance please start your own topic in a new thread. Thanks!
Chris Fistonich
Research Team

Posted Image

Follow us: Twitter, Become a fan: Facebook




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users