Jump to content


Photo

Receiving RegSetValueEx code 5 error at end of install


  • Please log in to reply
2 replies to this topic

#1 gssites

gssites

    New Member

  • Members
  • Pip
  • 2 posts

Posted 12 January 2009 - 03:56 PM

Hello,

Haven't run into this before; received this message when trying to install version 1.32:

Error writing to registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce

RegSetValueEx failed; code 5.
Access is denied.

Click Retry to try again, Ignore to proceed anyway, or Abort to cancel installation.

I am running Windows XP SP3, IE7 with latest updates. I am logged in with an account which is a Local Administrator (in fact a Domain Administrator). I've tried uninstalling/reinstalling. The installation will finish if I Ignore, but it won't let me connect to get updates. I ran a scan and it is coming up clean. Any ideas?

Thanks, Greg

#2 AdvancedSetup

AdvancedSetup

    Staff

  • Root Admin
  • PipPipPipPipPipPip
  • 41,383 posts
  • Gender:Male
  • Location:US

Posted 12 January 2009 - 04:55 PM

Check the permissions on that key. Error 5 means you don't have permissions for one reason or another.

#3 gssites

gssites

    New Member

  • Members
  • Pip
  • 2 posts

Posted 13 January 2009 - 10:45 AM

Thanks, AdvancedSetup.

Dug deeper and figured it out. The writing of the RunOnce key was being blocked by a new version/rule set of McAfee VirusScan. By adding MBAM-SETUP.TMP to the particular rule's exclusions list within McAfee, the problem was resolved. Interestingly, I also had to add MBAM.EXE to another rule's exclusion list so that Internet updates would be allowed.

Greg




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users