Sign in to follow this  
Followers 0
NYScott29

keyboard, mouse won't work

2 posts in this topic

1st, I would like to say that I managed to get this problem fixed and do not need any more help. However, I have seen several other posts from people who have had the exact same problem I had, but no solutions were ever posted. The topics were all closed, so I could not add a reply, but I wanted to post the solution that worked for me in hopes it may help someone else down the road.

I run windows XP w/service pack 3. The anti-virus program I use is Viper from sunbelt software. Recently, I managed to get a virus that viper could not clean from the computer. On Sunbelt's customer service site, I was told to download Malwarebytes, and run a complete scan of both Viper and Malwarebytes in "safe mode with networking on". I did so. Viper WAS able to quarantine and delete the virus. Malwarebytes, too, worked quite well, and found 68 additional threats which were quarantined. Malwarebytes directed me to restart the system to fully eradicate the threats, which I did. However, upon rebooting the system, neither my keyboard nor my mouse would work. I could not maneuver the cursor to click on my account, and further, my computer is password protected, so I couldn't log on if I did. I restarted the computer and went back to the startup menue (my keyboard DID work in the startup menue only). I tried restarting in safe mode, as well as all kinds of different configurations, etc - nothing worked to fix the problem.

I went online on my office computer to both Viper's and Malwarebytes' forums looking for help. I found several similar cases (and a couple EXACTLY the same as mine) with many recommendations on what to try to fix the problem, but no answers. Several people had asked what kind of ports the keyboard and mouse were plugged into (USB or PS/2); and one person had suggested that maybe the drivers for the keyboard and mouse had been corrupted by malware, and that, therefore, now that the malware had been removed, the mouse and keyboard would no longer work.

Both my keyboard and mouse at home are PS/2 connectors, while my keyboard and mouse at work are USB. What I did, was take my keyboard and mouse home from work, and plugged them into USB ports on my computer, hoping that would fix the problem. Neither would work at all. Then I went through the startup menue again, and pressing "del" during startup on my original keyboard (plugged into the PS/2 port), I found the system BIOS. There was a setting for both "USB Connected Keyboard" and "USB Connected mouse" (I know different systems are set up differently - for mine it was under "periferals"). Both of these were set to "disable". I changed both so that they said "enable", saved it and restarted the system. NOW the USB keyboard worked (still not the mouse). After windows started up, I was able to use the arrow keys on the USB keyboard to log onto my account. Shortly after I was logged on, the "add new hardware wizard popped up", saying it recognized new hardware plugged in. After that, the USB mouse started working. From then I went into "device manager" via start/settings/control panel/performance and maintenance/system. There I clicked on the "hardware" tab, and then "device manager". Looking through the list, there was a problem with the drivers for both the PS/2 Connected mouse and keyboard (apparently, they HAD been infected by some of the malware that I had removed). I clicked on both of them, and then clicked "uninstall". Then I went back to the control panel, then to "printers and other hardware" and then "add hardware". The add hardware wizard popped up, which searched online for drivers for both the PS/2 keyboard and mouse, and re-installed both. Now both work perfectly fine.

I want to thank the other members of this forum, who, if it had not been for their suggestions, I would never had thought to try the things I did. I hope if anyone else has a similar problem to what I had, that this will help.

Share this post


Link to post
Share on other sites

Hello and :welcome:

Thanks for sharing your experience, and as you said, it may help others as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.