Malwarebytes system file is corrupt

2 posts in this topic

I did a scan with malwarebytes anti malware and I deleted all the files it came up with.

Now I can't boot into windows because I just get a black screen with 'Windows could not start because the following file is missing or corrupt. \windows\system32\config\system

Windows repair install won't work.

I also can't get any system restore directory in the recovery console.

Is there anyway I can restore the system file from malwarebytes quarantine via recovery console?

Is there anything I can do to get the pc working again without lossing all the files that were on it?

Share this post

Link to post
Share on other sites

Hi, quinnd6: :)

Yes, some of today's rootkits and other nasty infections can cause serious system damage. :(

You'll need some expert guidance with this.

We cannot work on malware removal in this sub-section of the forum, so please read below for assistance with cleaning your system.

(If you have your Windows OS disks or a repair disk, and a USB flash drive ("thumb drive"), you might want to have them available.)

IMPORTANT: Please do NOT use any temporary file cleaners unless instructed to do so - they can cause data loss, making recovery difficult.

There are some excellent, self-help tutorials on getting MBAM to run on an infected system in the FAQ: HERE and in the KB section: HERE.


OPTION 1: Free, one-on-one, expert assistance in the Malware Removal Forum.

OPTION 2: For licensed users of MBAM PRO, there is free, one-on-one, expert assistance from the MBAM support helpdesk.

OPTION 3: Fee-based, one-on-one, expert assistance from Premium Support.


  • Please print out, read and carefully follow the instructions in the "I'm Infected - What Do I Do Now?" sticky topic.
  • -->If the infection has so crippled the computer that you cannot complete some or all of the steps, then just do the best you can and start a new topic as described below.
  • Then please start a new post in the Malware Removal Forum.
  • An authorized, trained malware expert will provide free, one-on-one assistance as soon as one becomes available.

  • -->>When starting your new post, please note the following:<<--
  • Please do NOT post in a topic started by someone else, even if their problem sounds similar.
  • Please COPY/PASTE the requested logs directly into your post, rather than attaching them.
  • Under options, please be sure to select "track this topic" and "immediate email notification", so you'll know when a helper responds.
  • Please be patient - it may be 48 hours or more before a helper can assist you, especially when the forum is very busy.
  • Please do NOT "bump" your topic or reply back to it for at least 48 hours.
  • Doing so may cause your topic to be overlooked, as it will appear that you are already being helped.


If you are a paid user of MBAM PRO and would like support via the helpdesk, please contact them HERE.


If you prefer the Malwarebytes Premium Services (comprehensive solutions to all your computer support needs – from installation and set-up to troubleshooting and tune-ups), please go to the Premium Support site HERE.

Please be patient – someone will assist you as soon as possible.

Thank you very much,


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.