skilz853

Installing MBAM 2.0

16 posts in this topic

Hey Folks,

 

I need some help.

 

I currently have Malwarebytes Pro installed at D:\Program Files (x86)\Malwarebytes' Anti-Malware\ (notice the ' at the end of Malwarebytes)

 

I just attempted to install 2.0 Premium and it offers to install to C:\ drive with the same folder except there's no ' at the end of Malwarebytes.

 

After reading the posts in the Introduction post about 2.0 Premium it seemed others were installing over their existing install of 1.75.0.1300 and it carried over their license when they did.

 

So my questions are, should I uninstall my current install and install 2.0 Premium in the default location (I know I can put it on D:\ drive if I choose to) and re-enter my license info, or can I install to the current folder and have the license carried over?

 

Thanks in advance for any help,

Skilz853

 

 

Share this post


Link to post
Share on other sites

You can manually install it and then  manually enter your license.  MBAM 2.0 will honor your old Lifetime license information.

 

If I were you, I'd actually use the clean uninstall process listed in https://forums.malwarebytes.org/index.php?showtopic=122284 to uninstall 1.75, then install MBAM 2.0 cleanly in a location of your choice, b/c there seems to be more than a few issues on upgraded machines that are getting solved by clean installs.

Share this post


Link to post
Share on other sites

Hey John,

 

Thanks for the quick reply. :)

 

I will follow your suggestions and get back if I have issues.

 

Skilz853

Share this post


Link to post
Share on other sites

Kewl beans.  Keep us posted, someone should be here if you have any issues :D

Share this post


Link to post
Share on other sites

Yes, do let us know how it goes, skilz853.

 

I'm rather curious because, IIRC, MBAM is designed to run best (properly?) only when installed to the default location (the boot drive, usually C:).

(AdvancedSetup or one of the staff will correct me if I am mistaken.)

 

I'll be interested to see how it does installed to a non-default location.

 

Cheers,

 

daledoc1

Share this post


Link to post
Share on other sites

I have \ProgramData moved to drive D: (Second SSD) and MBAM works perfectly fine.  I'm betting that installation location in and of itself should not be an issue as long as the installer is used ot pick the installation location.

 

Now, if a user were to manually move the installed files, I can see how that might cause a problem....

Share this post


Link to post
Share on other sites

Just to update you guys, I've decided to wait until the scan issues are sorted with rootkit scans and such. Also my license is from TrialPay and am concerned with it working from scratch again, as I've always updated from inside MBAM, so I may wait until in-program update comes out, so I won't have to deal with the folder being Malwarebytes with an apostrophe or without.

 

I'll update this when I eventually update MBAM,

Skilz853

Share this post


Link to post
Share on other sites

In program updates are already live, but it seems to be rolling out in phases.  My mother's machine was updated automatically from 1.75, keeping her key.

Share this post


Link to post
Share on other sites

John,

 

Do you know if your mother's 1.75 install was at Malwarebytes' and 2.0 went to Malwarebytes without the ' ?

 

Skiz853

Share this post


Link to post
Share on other sites

Yes, the folder structure will change between the two versions.

Share this post


Link to post
Share on other sites

Yes, we've removed the apostrophe (') from all paths and references to Malwarebytes Anti-Malware in version 2.0.

Share this post


Link to post
Share on other sites

Hey all, just looking at this thread and feeling behind on the update stuff. So my machine will automatically update to the new version? Glad for that, as I was thinking that would be the simplest. 

 

 MBAM looking and working great, as always.

Share this post


Link to post
Share on other sites

Yes, we've removed the apostrophe (') from all paths and references to Malwarebytes Anti-Malware in version 2.0.

Don't you think that was kinda stupid? Shouldn't the default path have been maintained for simplified over-the-top update to 2.0?

Share this post


Link to post
Share on other sites

No actually the apostrophe has always been an issue for command line use as it is also used in some cases as a quote character.  Using in scripts has always made it difficult to deal with for many customers.  For the average home user that does no special work or coding with the program then it doesn't make much difference either way.  Many users including employees have long asked for it to be removed and finally we dealt with it in 2.0 to finally get rid of it. 

 

Thanks

Share this post


Link to post
Share on other sites

Excellent that the the apostrophe has been removed!   Not that it ever caused me any issues over my many of use, it was just, in my view and unnecessary nuisance...  I just want to say that I installed version 2x on both my Windows 7 Po desktops (32 and 64 bit) without any any issues whatsoever, and that the new version was immediately named without the apostraphe, and changed from Pro to Premium (very much better!) and that, on both machines, my ID # and license code was carried over.

 

The only issue I have ever had with MBAM is that the previous stopped automatically updating, and I had it manually.   I obtained the fix from Mbam support by email, but, well, too complicated for an old man...  

 

Version 2 - really beautifully done MBAM!

 

Cheers! 

Share this post


Link to post
Share on other sites

I just want to say that I installed version 2x on both my Windows 7 Po desktops (32 and 64 bit) without any any issues whatsoever, and that the new version was immediately named without the apostraphe, and changed from Pro to Premium (very much better!) and that, on both machines, my ID # and license code was carried over.

BallyIrish,

 

That is really welcomed news, as that was my reason for thinking the default path should have been maintained.

 

Skilz853

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.