G-gran

Windows block Malwarebytes at startup?

16 posts in this topic

Sorry if I am asking in the wrong place but why are windows doing this? I have to click on it everytime. I have Vista Home Premium.

Share this post


Link to post
Share on other sites

Greetings and welcome G-gran <_<

Please take a look at the topic located here and see if it resolves the issue for you.

Please let me know how it goes.

Thanks ;)

Share this post


Link to post
Share on other sites
Greetings and welcome G-gran ;)

Please take a look at the topic located here and see if it resolves the issue for you.

Please let me know how it goes.

Thanks :D

Thank you for the welcome.

I am afraid I tried several times & it said the fix had been added to the registry but when I rebooted, the same old message was there. I tried it both on IE and Firefox. I am a bit of a dumbo so may have done something wrong. <_<

Share this post


Link to post
Share on other sites

Hello again <_<

Please do the following to give me a bit more information about your operating system version:

  • Click on the Vista Start vista-7-start.png button and right-click on Computer and select Properties
  • Look under Sytem for the entry called System type: and let me know if it says 32-bit Operating System or 64-bit Operating System

Thanks ;)

Share this post


Link to post
Share on other sites
Hello again <_<

Please do the following to give me a bit more information about your operating system version:

  • Click on the Vista Start vista-7-start.png button and right-click on Computer and select Properties
  • Look under Sytem for the entry called System type: and let me know if it says 32-bit Operating System or 64-bit Operating System

Thanks ;)

It is a 32-bit Op' System..

Share this post


Link to post
Share on other sites

Thank you, that should help <_<

Now please do the following so I can take a look at where the blocked startup entry is coming from:

  • Please copy and paste the following text exactly as written into notepad (not wordpad or any other text editor):
    @echo off
    reg query "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /s>"%userprofile%\desktop\Startups.txt"
    reg query "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /s>>"%userprofile%\desktop\Startups.txt"
    reg query "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce" /s>>"%userprofile%\desktop\Startups.txt"
    reg query "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce" /s>>"%userprofile%\desktop\Startups.txt"
    del /f /q %0

    Once you've done that click on File and select Save As...

  • In the Save dialogue box click on the drop down menu next to Save as type and select All Files
  • Name the file Check.bat (the .bat extension is very important)
  • Save the file to your desktop and double click it to run it.
  • Once it finishes you will find a file called Startups.txt on your desktop, right click on it and hover your mouse over Send To and select Compressed (zipped) Folder
  • Please attach the Startups.zip file you just created to your next reply

Thanks ;)

Share this post


Link to post
Share on other sites
Thank you, that should help <_<

Now please do the following so I can take a look at where the blocked startup entry is coming from:

  • Please copy and paste the following text exactly as written into notepad (not wordpad or any other text editor):
    @echo off
    reg query "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /s>"%userprofile%\desktop\Startups.txt"
    reg query "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /s>>"%userprofile%\desktop\Startups.txt"
    reg query "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce" /s>>"%userprofile%\desktop\Startups.txt"
    reg query "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce" /s>>"%userprofile%\desktop\Startups.txt"
    del /f /q %0

    Once you've done that click on File and select Save As...

  • In the Save dialogue box click on the drop down menu next to Save as type and select All Files
  • Name the file Check.bat (the .bat extension is very important)
  • Save the file to your desktop and double click it to run it.
  • Once it finishes you will find a file called Startups.txt on your desktop, right click on it and hover your mouse over Send To and select Compressed (zipped) Folder
  • Please attach the Startups.zip file you just created to your next reply

Thanks ;)

Hope I have done this properly????

Startups.zip

Share this post


Link to post
Share on other sites

Well done, that's what I needed to see <_< . It appears that this should be removed by the fix listed as startup_fix.zip posted here, but it's possible that the change the fix tries to make to the registry is being blocked by one of your other security softwares, likely TeaTimer.

Please do the following to temporarily disable it:

  • Please run Spybot Search & Destroy and click the Mode button at the top and select Advanced. Answer Yes to the window that pops up.
  • Expand the section on the left called Tools then click the Resident button (it should look like an orange shield)
  • In the main program you should see some options under Resident protection status
  • Please uncheck the box next to Resident TeaTimer and answer Yes to any prompts and exit Spybot Search & Destroy.
  • Right-click on the TeaTimer tray icon next to your clock (it should look like a small white box with a small silver pad-lock) and select Exit Spybot-S&D Resident

Once that is finished, try running the startup_fix.reg file again and restart your PC. Once you've done that and confirmed that Malwarebytes' is no longer being blocked at startup, reverse the above steps to re-enable TeaTimer and reboot your PC so that TeaTimer will run normally.

Please let me know how everything goes or if you have any questions about the procedure.

Thanks ;)

Share this post


Link to post
Share on other sites
Well done, that's what I needed to see :D . It appears that this should be removed by the fix listed as startup_fix.zip posted here, but it's possible that the change the fix tries to make to the registry is being blocked by one of your other security softwares, likely TeaTimer.

Please do the following to temporarily disable it:

  • Please run Spybot Search & Destroy and click the Mode button at the top and select Advanced. Answer Yes to the window that pops up.
  • Expand the section on the left called Tools then click the Resident button (it should look like an orange shield)
  • In the main program you should see some options under Resident protection status
  • Please uncheck the box next to Resident TeaTimer and answer Yes to any prompts and exit Spybot Search & Destroy.
  • Right-click on the TeaTimer tray icon next to your clock (it should look like a small white box with a small silver pad-lock) and select Exit Spybot-S&D Resident

Once that is finished, try running the startup_fix.reg file again and restart your PC. Once you've done that and confirmed that Malwarebytes' is no longer being blocked at startup, reverse the above steps to re-enable TeaTimer and reboot your PC so that TeaTimer will run normally.

It worked! Thank you so much, bless your heart!! <_<;)

Please let me know how everything goes or if you have any questions about the procedure.

Thanks :)

Share this post


Link to post
Share on other sites
It worked! Thank you so much, bless your heart!! <_<;)
You're very welcome, I'm glad to be of service :D .

Should you need anything else, just post.

Thanks :)

Share this post


Link to post
Share on other sites

Hi, I'm new to Malwarebytes and I have a question related to startup. Does Malwarebytes have to run upon startup? Is there a way to turn it off if you want?

Thank you!

Lynne

Share this post


Link to post
Share on other sites

Greetings and welcome ;)

The free version does not run at startup, this issue was a problem with Malwarebytes' cleaning engine that needed to run once after cleaning an infection and wasn't removing its own startup entry as it should. This problem has been corrected since version 1.42 of Malwarebytes' Anti-Malware and the current version is 1.44.

Share this post


Link to post
Share on other sites
Greetings and welcome :D

The free version does not run at startup, this issue was a problem with Malwarebytes' cleaning engine that needed to run once after cleaning an infection and wasn't removing its own startup entry as it should. This problem has been corrected since version 1.42 of Malwarebytes' Anti-Malware and the current version is 1.44.

That must be what I saw, then. Thank you so much for your help! ;)

Share this post


Link to post
Share on other sites

I'm having the same problem except I'm running version 1.50.1.1100 of the free trial version. Everytime Windows starts I get the Windows blocked program from starting. It appears that the problem wasn't entirely fixed in version 1.42. I'm running Vista in 32 bit mode.

I haven't tried the fix yet but I thought you should know that the problem still exists.

Share this post


Link to post
Share on other sites

Greetings and welcome :)

This issue should not exist in version 1.50 of Malwarebytes' Anti-Malware. If you are experiencing this issue, the following should correct it:

  • Click on START and click on Computer
  • Open C: and go to Program Files This will be Program Files (x86) for 64 bit Windows versions
  • Open the Malwarebytes' Anti-Malware folder
  • Find mbamgui.exe and right-click on it and choose Properties
  • Click on the Compatibility tab and uncheck Run this program as an adiminstrator and click on Apply then click OK
  • Restart your computer and the issue should be resolved

Please let me know if that corrected the problem or not.

Thanks :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.