Sign in to follow this  
Followers 0
lister

runtime error 383

15 posts in this topic

Every time I update the program using the updater (not the definitions) I get a new runtime error and have to clean install.

Or, like this time, MB seems to be working (icon in the system tray) yet when I try and scan a folder/file or open the GUI there is ANOTHER runtime error. This time it's...

Run-time error '383'

'Text' property is read-only

What is the point of an anti-malware that is so unreliable?

Share this post


Link to post
Share on other sites

Well, Run-time error 383 means "Property Set can't be used with a read-only property", so I'm going to have to assume that something else is interfering with Malwarebytes' Anti-Malware here.

Please add the following file to the exclusions list in your anti-virus software:

C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe

Share this post


Link to post
Share on other sites

I had already excluded the path (C:\Program Files\Malwarebytes' Anti-Malware\*) from my AV.

Share this post


Link to post
Share on other sites

The issue is a lot more complex due to how Malware infects your system in the first place. Your Anti-Virus and Firewall and depending on what other security software you run, also need to be told to allow MBAM to run and do it's job otherwise you will continue to have such issues.

What operating system are you running and what Anti-Virus and other security software are you running? Is Windows a clean install or an upgrade from a previous Windows version installation?

Share this post


Link to post
Share on other sites

XP pro sp3. avast! home and Online Armor.

I added the mbam.exe exclusion but won't be able to see if that fixes it as I re-installed MB.

Share this post


Link to post
Share on other sites

Well unfortunately we do not have a walk through article on Avast or Online Armor but I do know that Online Armor has blocked MBAM many times for users. The problem though is that once it's blocked it you often now end up with a partial update and/or corrupted installation of MBAM.

For Avast it's difficult to tell as we've seen some users claim they need exclusions setup and others that say they've not needed them. The best advice I can give for that is to review the other AV program exclusions in the FAQ and as best as possible attempt to duplicate them in Avast and Online Armor.

McAfee: http://www.malwarebytes.org/forums/index.p...&pid=162098

Trend: http://www.malwarebytes.org/forums/index.p...&pid=162099

AVG: http://www.malwarebytes.org/forums/index.p...&pid=167851

Each AV is different, but the general idea is to find where and how the AV is blocking and add an exclusion so that the update is never even temporarily blocked as even that temporary block can affect the overall update which may be why you're needing to do the clean removal.

Share this post


Link to post
Share on other sites

Hello,

sorry to bump into existing topic, but I didn't want to start something new on this error code.

Runtime error 383 => "Property Set can't be used with a read-only property"

This also happens when users delete some language files, they think some files are unneeded, and simply go to the languages folder and keep only one. ;)

I was a bit surprised, and tried it. The message immediately appeared. I told the users not to touch MBAM's files, of course.

Share this post


Link to post
Share on other sites

Yes that has been reported before and is supposed to be fixed in the next version.

Thank you.

Share this post


Link to post
Share on other sites

And thanks for fixing this so fast. ;)

Share this post


Link to post
Share on other sites

Please help me as soon as possible. I use your product for many years now, i updated as asked to 1.60 version today and i get this error for the fist time. I strongly believe it has to do with the greek language file i used to till today and is not included in your new version. I use windows xp sp3. Thanks

Share this post


Link to post
Share on other sites

Greeting and Welcome to Malwarebyte :)

Thank you for your supports ! I suggest you to start a new topic so an expert can look at your problems.

Alternatively as a paying consumers , you can contact Malwarebyte Helpdesk :

http://helpdesk.malwarebytes.org

Regards,

Share this post


Link to post
Share on other sites

I just solved it, i downloaded the new greek language file uploaded here and worked just fine...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.