firstlinecomp

mbamservice.exe causing severe slowdown

40 posts in this topic

I am working on three computers, one is mine, the other two are two separate clients, where mbamservice.exe is causing severe slowdown at random.

The only common denominator I see at this point is that all three are running quickbooks, different versions on each computer.

This severe slowdown has started since the MBMA program update on March 29, 2010.

Currently I have MBAM completely disabled on all three computers to see if it is the culprit.

MBAM is an awesome program for cleaning malware out of a computer and for protecting future malware infections.

I hate that I've had to disable the protection on these computers so that they can be used for daily work.

Thank you for your help!

Share this post


Link to post
Share on other sites

What other security software do you run with them?

(in particular, anti-virus software)

Share this post


Link to post
Share on other sites

Two of the computers have AVG 9.0, and the other computer has Symantec Corporate Edition.

I now have another computer that the severe slowdown would happen when they tried to print to a printer connected to another computer on their network.

All of these issues started after the 1.45 update, and so far have disappeared when I disable the mbamservice.

Thank you.

Share this post


Link to post
Share on other sites

I am having the same problem. Interesting enough, the machine that is experiencing the slowdown is a Quickbooks multi user server. A second, identical system, is not a quickbooks server and is not having a problem. MB is the only AV software on both machines. I run MB on 3 other systems without quickbooks and non are experiencing the problem. Now, quickbooks could just be a coincidence, but the slowdown is a real problem and I am going to have to pull MB off the system if I can't find a fix.

Share this post


Link to post
Share on other sites

turn off website blocking and see if that helps

fixed my slow network speed and computer slowdown

Share this post


Link to post
Share on other sites

Also, with AVG, please make sure you exclude Malwarebytes' Anti-Malware's files as detailed here note the separate instructions for version 9.

Share this post


Link to post
Share on other sites

I turned off website blocking and the service stopped chewing up CPU. Quickbooks was working normally this AM.

Share this post


Link to post
Share on other sites

Hello again,

That's actually a good sign, it means that your issue will likely be corrected when the next version of Malwarebytes' Anti-Malware is released as the Website Blocking component was changed to correct several performance issues that users have been having.

I do not have a release date for 1.46 yet but I do no that it is in active development so it shouldn't be too long.

For the time being you may wish to disable Website Blocking until version 1.46 is released. To do so do the following:

  • Open Malwarebytes' Anti-Malware and click on the Protection tab
  • Uncheck the box next to Start malicious website blocking when protection module starts.
  • Restart your computer

Reverse these steps once 1.46 is released and you've installed it then test to see if it did indeed resolve the problem for you.

If you require anything further please post.

Thanks

Share this post


Link to post
Share on other sites

I'm having a similar problem. I'm using Avast AV, but I haven't seen any indication of that being involved. I did notice that MBAM started cranking way up as soon as Memeo Autobackup started running, doing an automated backup to an external drive. MBAM's CPU usage is pretty relentlessly over 50%, though it jumps up and down constantly. It's not unusual to see it in the 80s and 90s.

Turning off website blocking and protection seems to have no effect on it at all. Shouldn't that cut it way back?

I'm using MBAM ver. 1.45.

Share this post


Link to post
Share on other sites
I'm having a similar problem. I'm using Avast AV, but I haven't seen any indication of that being involved. I did notice that MBAM started cranking way up as soon as Memeo Autobackup started running, doing an automated backup to an external drive. MBAM's CPU usage is pretty relentlessly over 50%, though it jumps up and down constantly. It's not unusual to see it in the 80s and 90s.

Turning off website blocking and protection seems to have no effect on it at all. Shouldn't that cut it way back?

I'm using MBAM ver. 1.45.

I played with it a little more, and what really seems to torque it off is bringing up Memeo's GUI. That immediately causes MBAM to start gobbling CPU cycles. And doesn't stop until I turn off Memeo's GUI and let it run totally in the background.

Share this post


Link to post
Share on other sites

I have the same CPU hugging problem with MBAM real-time with both VIPRE 4 a/v and Avira 9 Premium.

So I think there's something wrong going with MBAM 1.45.

For the time being, I simply disabled MBAM's real-time protection.

Now waiting for the fix!

Share this post


Link to post
Share on other sites

Closer observation indicates that the CPU usage shoots up--and stays up--when I use any of several common applications: Winword, Firefox, Calibre ebook manager. I'm working most of the time with CPU at 100% total, and a sizable chunk of that being mbamservice.exe. Effect on performance is sometimes quite noticeable, other times not.

Share this post


Link to post
Share on other sites

Hi starrigger

I turned off website blocking and the service stopped chewing up CPU - Was working normally this AM.

Still updates and runs scans as scheduled

- (Temp fix only until the 1.46 patch is released ) -

Thanks - :)

Share this post


Link to post
Share on other sites
Hi starrigger

I turned off website blocking and the service stopped chewing up CPU - Was working normally this AM.

Still updates and runs scans as scheduled - (Temp fix only until the 1.46 patch is released ) -

Thanks - :)

Unfortunately, turning off website blocking had no effect on my issue. That's on my XP machine.

I just checked my Win7 computer, and it's experiencing no such problems. I wonder if I should try reinstalling MBAM on the XP.

Share this post


Link to post
Share on other sites

It's worth a shot, please try the following:

Windows XP:

  • Click on Start and select Control Panel
  • Open Add/Remove Programs
  • Uninstall Malwarebytes' Anti-Malware
  • Restart your computer very important
  • Download and run mbam-clean.exe from here
  • It will ask to restart your computer, please allow it to do so very important
  • After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from here
    • Note: You will need to reactivate the program using the license you were sent via email if using the Pro version
    • Launch the program and set the Protection and Registration. Then go to the UPDATE tab if not done during installation and check for updates.
      Restart the computer again and verify that MBAM is in the task tray if using the Pro version. Now setup any file exclusions as may be required in your Anti-Virus/Internet-Security/Firewall applications and restart your Anti-Virus/Internet-Security applications. You may use the guides posted in the FAQ's here or ask and we'll explain how to do it.

Windows Vista and Windows 7:

  • Click on the Start vista-7-start.png button and select Control Panel
  • Click on Programs and Features
  • Uninstall Malwarebytes' Anti-Malware
  • Restart your computer very important
  • Download and run mbam-clean.exe from here
  • It will ask to restart your computer, please allow it to do so very important
  • After the computer restarts, temporarily disable your Anti-Virus and install the latest version of Malwarebytes' Anti-Malware from here
    • Note: You will need to reactivate the program using the license you were sent via email if using the Pro version
    • Launch the program and set the Protection and Registration. Then go to the UPDATE tab if not done during installation and check for updates.
      Restart the computer again and verify that MBAM is in the task tray if using the Pro version. Now setup any file exclusions as may be required in your Anti-Virus/Internet-Security/Firewall applications and restart your Anti-Virus/Internet-Security applications. You may use the guides posted in the FAQ's here or ask and we'll explain how to do it.

Please let us know how it goes.

Thanks :)

Share this post


Link to post
Share on other sites

OK, I did all that above (reinstall). At first I thought--hey, this is really better. I'd watch the CPUs in Task Manager while opening and closing and running different programs, and MBAM would seem to jump way up for a few seconds at a time, but then it would settle down again.

However, the longer I followed it, the more it would seem to want to stay up in higher numbers. Finally, it was just like before. Except that this time, when I shut down all the other apps, it finally dropped, too. Then started up again, when I reopened programs.

Hm, I just looked right now, and it had dropped again.

So I'm not sure. I wish I could just keep an eye on the little systray CPU meter. But since Word also likes to hog CPU cycles when nothing else is happening, it's hard to monitor.

I don't seem to be feeling the hit on performance that I was before. So maybe the reinstall did do some good.

Share this post


Link to post
Share on other sites

That sounds pretty normal. The CPU usage will climb briefly whenever a new process is executed as it's being analyzed by MBAM. It should settle down but if it doesn't, then also make sure to set the appropriate exclusions in your resident antivirus and firewall for MBAM:

For Windows XP:

  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamgui.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe
  • C:\Program Files\Malwarebytes' Anti-Malware\zlib.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbam.dll
  • C:\Program Files\Malwarebytes' Anti-Malware\mbamext.dll
  • C:\Documents and Settings\All Users\Application Data\Malwarebytes\Malwarebytes' Anti-Malware\rules.ref
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\System32\drivers\mbamswissarmy.sys

I realize you've likely already done this, but I posted it here just in case you hadn't and also for the benefit of any others that may be having this issue that should come across this thread.

Also, there's nothing set in stone yet, but I do believe there should be some performance improvements in the upcoming release so hopefully that will help out as well.

Share this post


Link to post
Share on other sites

Hello,

I too have been having the same problem with MBAMservice spiking my cpu every few seconds and causing a real slowdown. I followed the above thread. Turning off ipblocking does not seem to help. I have uninstalled and resinstalled as per your instructions above. I have listed MBAM in the exceptions of windows firewall (but that is all) and I have added all of the entries in your list above into the exceptions of avira antivir (both under scan and under Guard). I put the entire list into file objects under guard, and under processes only mbam.exe and mbamservice.exe. I am running windows xp sp3 on a pentium 4 1.99Mhz with 2.0 GB RAM. If I let my computer be idle and just watch the task manager, MBAM continues to spike the cpu into the 70s and 80s very briefly every few seconds.

Any more suggestions?

thank you,

J

Share this post


Link to post
Share on other sites

I have attached a screenshot of the spikes as seen with task manager. all of the spikes are mbamservice. nothing else goes above 3 or 4 % (other than system idle process of course).

post-33303-1272396625_thumb.jpg

Share this post


Link to post
Share on other sites

Greetings jhill :)

Please do the following:

Create an Autoruns Log:

  • Please download Sysinternals Autoruns from here and save it to your desktop.
    • Note: If using Windows Vista or Windows 7 then you also need to do the following:
      1. Right-click on Autoruns.exe and select Properties
      2. Click on the Compatibility tab
      3. Under Privilege Level check the box next to Run this program as an administrator
      4. Click on Apply then click OK

    [*]Double-click Autoruns.exe to run it.

    [*]Once it starts, please press the Esc key on your keyboard.

    [*]Now that scanning is stopped, click on the Options button at the top of the program and select Verify Code Signatures

    [*]Once that's done press the F5 key on your keyboard, this will start the scan again, this time let it finish.

    [*]When it's finished, please click on the File button at the top of the program and select Save and save the Autoruns.arn file to your desktop and close Autoruns.

    [*]Right click on the Autoruns.arn file on your desktop and hover your mouse over Send To and select Compressed (zipped) Folder

    [*]Attach the Autoruns.zip folder you just created to your next reply

Thanks :)

Share this post


Link to post
Share on other sites

Hello again :)

Please save your license/key info and temporarily uninstall TuneUp Utilities and then restart your computer.

Let me know if that has any effect on the issue with mbamservice.exe

Thanks :)

Share this post


Link to post
Share on other sites

Mine's at it again--hanging up there in the 80s and 90s on the CPU meter, for no obvious reason. I had a bunch of apps open, and experienced pretty noticeable slowdown, with the CPU running at 100% for quite a while, and MBAM being most of that. I closed some of the apps, but it didn't make much difference. With just Firefox, Word, Outlook, and Windows explorer open, it's staying pretty high. I expect I'll see it drop some when I close Firefox; I often do.

This hasn't been happening consistently. It seems if I get a lot of stuff running, MBAM races, and then doesn't want to stop racing. Maybe it's just competitive. :)

Share this post


Link to post
Share on other sites
Hello again :)

Please save your license/key info and temporarily uninstall TuneUp Utilities and then restart your computer.

Let me know if that has any effect on the issue with mbamservice.exe

Thanks :)

Hi exile,

I uninstalled tuneup utilities. AFter restart, no change. Mbamservice.exe continues to spke theCPU constantly. Nothing else is going over 2 or 3 percent, most are 0.

thank you,

J

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.