Docfxit

Run-time error '372' vbalsgrid6.ocx

48 posts in this topic

When I run Mbam.exe I get:

Run-time error '372':

Failed to load control 'vbalGrid' from vbalsgrid6.ocx. Your version of vbalsgrid6.ocx may be outdated. Make sure you are using the version of the control that was provided with your application.

I have uninstalled Malwarebytes. I have downloaded ver. 1.15 today and installed it. I'm still getting the error. The version I have is 2.0.0.40.

I have run:

regsvr32 vbalsgrid6.ocx

within the Malwarebytes folder. It did say it was successful.

Any ideas on what might fix this are welcome.

Thank you,

Docfxit

Share this post


Link to post
Share on other sites
What operating system are you using and what service pack?

Sorry I didn't specify that the first time.

XP Pro SP2

Thank you,

Docfxit

Share this post


Link to post
Share on other sites

Do a search for vbalsgrid6.ocx and see if it's located elsewhere on the system.

Make sure to search including hidden and system folders under options. The search your entire computer.

Let us know if it finds another copy somewhere else.

Share this post


Link to post
Share on other sites
Do a search for vbalsgrid6.ocx and see if it's located elsewhere on the system.

Make sure to search including hidden and system folders under options. The search your entire computer.

Let us know if it finds another copy somewhere else.

There are no other copies on the computer.

It appears like that program needs a service started. I found a number of services that won't start.

Wouldn't you know it. Just when I need to find and remove what ever is causing havoc with this PC I can't run it.

Thank you,

Docfxit

Share this post


Link to post
Share on other sites
Please post a new log in this forum and we'll start working on removing Malware from your system.

HJT Forum

First try to run the instructions from here if you can

Pre- HJT Post Instructions

.

Thank you for helping me.

I am currently running CA Antivirus (fully updated)

Next I will run SpyBot 1.52

I can't run Malwarebytes because I get the error I listed in post #1

I will be back as soon as the scans finish.

Thank you,

Docfxit

Share this post


Link to post
Share on other sites

I tried running Panda Scan. I tried running it in Firefox. I downloaded the file. I launched the file. I pressed continue.

It wanted to download the file again. It couldn't.

I tried running it in IE. It wouldn't run at all.

I tried ESET. I accepted the terms. I clicked on start and nothing happened.

Ad-Aware won't run.

I ran Spybot 1.52

I ran CA Antivirus.

When You said: To post a HJT log in this forum did you mean this thread or the HJT forum?

I am not permitted to upload a log file in this thread.

Thank you,

Docfxit

Share this post


Link to post
Share on other sites

Please post in the HJT Forum and just copy/paste into the window - don't attach the file.

Share this post


Link to post
Share on other sites

I replied in the HJT forum, didn't see this. Panda will not run with Firefox. Most online scans won't because they use ActiveX you must us IE and you must run as an administrator.

Seems to be a bug in MBAM right now, I can't get a scan to run and there is another post.

Share this post


Link to post
Share on other sites

If you cannot get the Panda scan to run, you can always try the Kaspersky Online Scan. Note that it requires Internet Explorer 6.0 or higher. If these will not work, you might be able to boot Windows into "Safe Mode With Networking" and run them there.

Share this post


Link to post
Share on other sites
If you cannot get the Panda scan to run, you can always try the Kaspersky Online Scan. Note that it requires Internet Explorer 6.0 or higher. If these will not work, you might be able to boot Windows into "Safe Mode With Networking" and run them there.

Hi I got the same Run-time error when double clicking on Malware icon.

Running in XP SP1.

Please help!!!!

Share this post


Link to post
Share on other sites
Hi I got the same Run-time error when double clicking on Malware icon.

Running in XP SP1.

Please help!!!!

Have you tried uninstalling Malwarbytes' Anti-Malware, then downloading the latest version (currently 1.16) and installing it?

Share this post


Link to post
Share on other sites
Have you tried uninstalling Malwarbytes' Anti-Malware, then downloading the latest version (currently 1.16) and installing it?

Seems that it was already the 1.16 version. I make a new try...

If it doesn't work??? What can I do?

With HijckThis may be? No?

Share this post


Link to post
Share on other sites
Seems that it was already the 1.16 version. I make a new try...

If it doesn't work??? What can I do?

With HijckThis may be? No?

Yes, please post a HijackThis log, and one of our experts will take a look at it for you.

You can also try the Kasperky Online Virus Scan to see what it finds.

Share this post


Link to post
Share on other sites
Thanks.

Doesn't work with version 1.16

I try downlowding the HiJackThis and post the report

Cross the fingers!

The Kaspersky Online Scan didn't work? Did you run it in Internet Explorer? It requires Internet Explorer version 6.0 or newer to work.

Share this post


Link to post
Share on other sites
The Kaspersky Online Scan didn't work? Did you run it in Internet Explorer? It requires Internet Explorer version 6.0 or newer to work.

Here is the report with HJT

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 18:03:40, on 10/06/2008

Platform: Windows XP SP1 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

Boot mode: Normal

Running processes:

C:\WINDOWS\System32\smss.exe

C:\WINDOWS\system32\winlogon.exe

C:\WINDOWS\system32\services.exe

C:\WINDOWS\system32\lsass.exe

C:\Program Files\Avira\AntiVir PersonalEdition Classic\sched.exe

C:\Program Files\Avira\AntiVir PersonalEdition Classic\avguard.exe

C:\WINDOWS\Explorer.EXE

C:\Program Files\Java\jre1.6.0_06\bin\jusched.exe

C:\Program Files\QuickTime\qttask.exe

C:\PROGRA~1\HPQ\ONE-TO~1\OneTouch.EXE

C:\WINDOWS\System32\carpserv.exe

C:\Program Files\Avira\AntiVir PersonalEdition Classic\avgnt.exe

C:\WINDOWS\System32\ctfmon.exe

C:\Program Files\RALINK\Common\RaUI.exe

C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar = http://go.compaq.com/2Q00CPT/040C/bF8.asp

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.compaq.com/2Q00CPT/040C/bF7.asp

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://desktop.presario.net/scripts/redire...;lc=040c&ac

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://search.presario.net/scripts/redirec...rch&ap=b204

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Bar = http://search.presario.net/scripts/redirec...rch&ap=b204

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://search.presario.net/scripts/redirec...rch&ap=b204

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://desktop.presario.net/scripts/redire...;lc=040c&ac

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Liens

O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 5.0\Reader\ActiveX\AcroIEHelper.ocx

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_06\bin\ssv.dll

O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx

O4 - HKLM\..\Run: [Watch] C:\PROGRA~1\Minitel\Watch.exe

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_06\bin\jusched.exe"

O4 - HKLM\..\Run: [srmclean] C:\Cpqs\Scom\srmclean.exe

O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime

O4 - HKLM\..\Run: [QT4HPOT] C:\PROGRA~1\HPQ\ONE-TO~1\OneTouch.EXE

O4 - HKLM\..\Run: [PreloadApp] c:\hp\drivers\printers\photosmart\hphprld.exe c:\hp\drivers\printers\photosmart\setup.exe -d

O4 - HKLM\..\Run: [KernelFaultCheck] %systemroot%\system32\dumprep 0 -k

O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"

O4 - HKLM\..\Run: [Display Settings] C:\Program Files\HPQ\Notebook Utilities\hptasks.exe /s

O4 - HKLM\..\Run: [Cpqset] C:\Program Files\HPQ\Default Settings\cpqset.exe

O4 - HKLM\..\Run: [CARPService] carpserv.exe

O4 - HKLM\..\Run: [avgnt] "C:\Program Files\Avira\AntiVir PersonalEdition Classic\avgnt.exe" /min

O4 - HKLM\..\Run: [ATIPTA] C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe

O4 - HKLM\..\Run: [ATIModeChange] Ati2mdxx.exe

O4 - HKCU\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\ctfmon.exe

O4 - HKCU\..\Run: [bitTorrent] "C:\Program Files\BitTorrent\bittorrent.exe" --force_start_minimized

O4 - HKUS\S-1-5-21-1383073748-863898074-1377682316-1006\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\ctfmon.exe (User '?')

O4 - HKUS\S-1-5-21-1383073748-863898074-1377682316-1006\..\Run: [bitTorrent] "C:\Program Files\BitTorrent\bittorrent.exe" --force_start_minimized (User '?')

O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User '?')

O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'Default user')

O4 - Global Startup: Microsoft Office.lnk = C:\Program Files\Microsoft Office\Office10\OSA.EXE

O4 - Global Startup: Ralink Wireless Utility.lnk = C:\Program Files\RALINK\Common\RaUI.exe

O9 - Extra button: Sites Perso - {06FE5D05-8F11-11d2-804F-00105A133818} - http://compaqnet.ifrance.com/heberg/accueil (file missing)

O9 - Extra 'Tools' menuitem: Compaq France - {06FE5D05-8F11-11d2-804F-00105A133818} - http://compaqnet.ifrance.com/heberg/accueil (file missing)

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_06\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Console Java (Sun) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_06\bin\ssv.dll

O9 - Extra button: Related - {c95fe080-8f5d-11d2-a20b-00aa003c157a} - C:\WINDOWS\web\related.htm

O9 - Extra 'Tools' menuitem: Show &Related Links - {c95fe080-8f5d-11d2-a20b-00aa003c157a} - C:\WINDOWS\web\related.htm

O23 - Service: Avira AntiVir Personal

Share this post


Link to post
Share on other sites
I replied in the HJT forum, didn't see this. Panda will not run with Firefox. Most online scans won't because they use ActiveX you must us IE and you must run as an administrator.

Seems to be a bug in MBAM right now, I can't get a scan to run and there is another post.

Thank you for finding this thread. I can't copy and paste with either the pulldown menus or <CTRL> C and <CTRL> V

I have tried to run Panda with IE and FireFox. With FireFox I did get further. When you are running FireFox you download a plugin called ActiveScan. I ran the plugin while I was out of FireFox. I ran FireFox and it said it had a problem downloading the plugin. I cleared the cache and ran FireFox again. It had the same error.

I tried going to http://www.pandasecurity.com/usa/ on a different computer and it doesn't work there either. It seems like they have an error on their web site.

I tried running IE in Safe Mode. I can't get it to go to any web site. I can ping yahoo.com successfully. I tried with and without "Automatically detect settings".

Firefox failed just as bad.

Thank you,

Docfxit

Share this post


Link to post
Share on other sites
If you cannot get the Panda scan to run, you can always try the Kaspersky Online Scan. Note that it requires Internet Explorer 6.0 or higher. If these will not work, you might be able to boot Windows into "Safe Mode With Networking" and run them there.

I can't get Kaspersky Online Scan to run in IE. Nothing happens when I click on the link.

Thank you,

Docfxit

Share this post


Link to post
Share on other sites
Thank you for finding this thread. I can't copy and paste with either the pulldown menus or <CTRL> C and <CTRL> P

CTRL+P is print. The paste shortcut is CTRL+V (which admittedly doesn't make a whole lot of sense).

Have you tried installing and runing version 1.17 of Malwarebytes' Anti-Malware? If not, download it from here.

Share this post


Link to post
Share on other sites
Here is the report with HJT

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 18:03:40, on 10/06/2008

Platform: Windows XP SP1 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

Boot mode: Normal

Any body can help?

This is the latest report from HJT

Running processes:

C:\WINDOWS\System32\smss.exe

C:\WINDOWS\system32\winlogon.exe

C:\WINDOWS\system32\services.exe

C:\WINDOWS\system32\lsass.exe

C:\Program Files\Avira\AntiVir PersonalEdition Classic\sched.exe

C:\Program Files\Avira\AntiVir PersonalEdition Classic\avguard.exe

C:\WINDOWS\Explorer.EXE

C:\Program Files\Java\jre1.6.0_06\bin\jusched.exe

C:\Program Files\QuickTime\qttask.exe

C:\PROGRA~1\HPQ\ONE-TO~1\OneTouch.EXE

C:\WINDOWS\System32\carpserv.exe

C:\Program Files\Avira\AntiVir PersonalEdition Classic\avgnt.exe

C:\WINDOWS\System32\ctfmon.exe

C:\Program Files\RALINK\Common\RaUI.exe

C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar = http://go.compaq.com/2Q00CPT/040C/bF8.asp

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.compaq.com/2Q00CPT/040C/bF7.asp

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://desktop.presario.net/scripts/redire...;lc=040c&ac

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://search.presario.net/scripts/redirec...rch&ap=b204

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Bar = http://search.presario.net/scripts/redirec...rch&ap=b204

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://search.presario.net/scripts/redirec...rch&ap=b204

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://desktop.presario.net/scripts/redire...;lc=040c&ac

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Liens

O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 5.0\Reader\ActiveX\AcroIEHelper.ocx

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_06\bin\ssv.dll

O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx

O4 - HKLM\..\Run: [Watch] C:\PROGRA~1\Minitel\Watch.exe

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_06\bin\jusched.exe"

O4 - HKLM\..\Run: [srmclean] C:\Cpqs\Scom\srmclean.exe

O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime

O4 - HKLM\..\Run: [QT4HPOT] C:\PROGRA~1\HPQ\ONE-TO~1\OneTouch.EXE

O4 - HKLM\..\Run: [PreloadApp] c:\hp\drivers\printers\photosmart\hphprld.exe c:\hp\drivers\printers\photosmart\setup.exe -d

O4 - HKLM\..\Run: [KernelFaultCheck] %systemroot%\system32\dumprep 0 -k

O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"

O4 - HKLM\..\Run: [Display Settings] C:\Program Files\HPQ\Notebook Utilities\hptasks.exe /s

O4 - HKLM\..\Run: [Cpqset] C:\Program Files\HPQ\Default Settings\cpqset.exe

O4 - HKLM\..\Run: [CARPService] carpserv.exe

O4 - HKLM\..\Run: [avgnt] "C:\Program Files\Avira\AntiVir PersonalEdition Classic\avgnt.exe" /min

O4 - HKLM\..\Run: [ATIPTA] C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe

O4 - HKLM\..\Run: [ATIModeChange] Ati2mdxx.exe

O4 - HKCU\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\ctfmon.exe

O4 - HKCU\..\Run: [bitTorrent] "C:\Program Files\BitTorrent\bittorrent.exe" --force_start_minimized

O4 - HKUS\S-1-5-21-1383073748-863898074-1377682316-1006\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\ctfmon.exe (User '?')

O4 - HKUS\S-1-5-21-1383073748-863898074-1377682316-1006\..\Run: [bitTorrent] "C:\Program Files\BitTorrent\bittorrent.exe" --force_start_minimized (User '?')

O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User '?')

O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'Default user')

O4 - Global Startup: Microsoft Office.lnk = C:\Program Files\Microsoft Office\Office10\OSA.EXE

O4 - Global Startup: Ralink Wireless Utility.lnk = C:\Program Files\RALINK\Common\RaUI.exe

O9 - Extra button: Sites Perso - {06FE5D05-8F11-11d2-804F-00105A133818} - http://compaqnet.ifrance.com/heberg/accueil (file missing)

O9 - Extra 'Tools' menuitem: Compaq France - {06FE5D05-8F11-11d2-804F-00105A133818} - http://compaqnet.ifrance.com/heberg/accueil (file missing)

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_06\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Console Java (Sun) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_06\bin\ssv.dll

O9 - Extra button: Related - {c95fe080-8f5d-11d2-a20b-00aa003c157a} - C:\WINDOWS\web\related.htm

O9 - Extra 'Tools' menuitem: Show &Related Links - {c95fe080-8f5d-11d2-a20b-00aa003c157a} - C:\WINDOWS\web\related.htm

O23 - Service: Avira AntiVir Personal

Share this post


Link to post
Share on other sites
Any body can help?

Thanks

I'm sorry, I should have asked you to create a new topic in the HijackThis Logs Forum. Please post your log in a new topic in that forum, and someone will help you out. wink_happy.png

Share this post


Link to post
Share on other sites
I'm sorry, I should have asked you to create a new topic in the HijackThis Logs Forum. Please post your log in a new topic in that forum, and someone will help you out. wink_happy.png

That's done!

Thanks

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.