Sign in to follow this  
Followers 0
TOSK

Incompatible with McAfee?

9 posts in this topic

I’ve been using the free version for a while now, caught some things

McAfee 2010 didn’t. While installing McAfee 2011 the other day,

McAfee warns me Malwarebytes is incompatible. I think it’s a McAfee scam.

Share this post


Link to post
Share on other sites

Hello TOSK:

You likely need to enter the following exclusions:

Set Exclusions for Malwarebytes' Anti-Malware in McAfee Total Protection 2011 on 32 bit Windows Versions:

  1. Open McAfee and click on Navigation in the upper right hand corner.
  2. Click on Firewall located under Features.
  3. Click on Program Permissions and wait for the list to populate.
  4. Click the Add button and then click browser.
  5. Add the following files to the firewall with full access:
    Note: On 64 bit Windows versions these files will be located in C:\Program Files (x86)\Malwarebytes' Anti-Malware
    • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
    • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe

[*]Click OK

[*]Close the McAfee main window and restart your computer.

Set Exclusions for McAfee Total Protection 2011 in Malwarebytes' Anti-Malware:

  • Open Malwarebytes' Anti-Malware and click on the Ignore List tab
  • Click the Add button on the lower left
  • In the small browse window that opens, navigate to C:\Program Files and click once on McAfee and click OK.
  • Click the Add button on the lower left
  • In the small browse window that opens, navigate to C:\Program Files and click once on McAfee.com and click OK.
    Note: For 64 bit Windows versions these folders will be in C:\Program Files (x86)
  • Close Malwarebytes' Anti-Malware

Please let us know how it goes. :)

Share this post


Link to post
Share on other sites

Hello TOSK:

You likely need to enter the following exclusions:

Set Exclusions for Malwarebytes' Anti-Malware in McAfee Total Protection 2011 on 32 bit Windows Versions:

  1. Open McAfee and click on Navigation in the upper right hand corner.
  2. Click on Firewall located under Features.
  3. Click on Program Permissions and wait for the list to populate.
  4. Click the Add button and then click browser.
  5. Add the following files to the firewall with full access:
    Note: On 64 bit Windows versions these files will be located in C:\Program Files (x86)\Malwarebytes' Anti-Malware
    • C:\Program Files\Malwarebytes' Anti-Malware\mbam.exe
    • C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe

[*]Click OK

[*]Close the McAfee main window and restart your computer.

Set Exclusions for McAfee Total Protection 2011 in Malwarebytes' Anti-Malware:

  • Open Malwarebytes' Anti-Malware and click on the Ignore List tab
  • Click the Add button on the lower left
  • In the small browse window that opens, navigate to C:\Program Files and click once on McAfee and click OK.
  • Click the Add button on the lower left
  • In the small browse window that opens, navigate to C:\Program Files and click once on McAfee.com and click OK.
    Note: For 64 bit Windows versions these folders will be in C:\Program Files (x86)
  • Close Malwarebytes' Anti-Malware

Please let us know how it goes. :)

Thanks for the reply. Going to have to spend some time under the covers. I’ll have to look at all the various settings cause when I click firewall I don’t have program permissions but do have “internet connection for programs” and Malwarebytes is already there. The incompatible message I received (2 days ago) was during McAfee installation, I uninstalled Malwarebytes then reinstalled after McAfee was done. I haven’t run a full McAfee 2011 scan yet. I’ll get back to you after I run a full scan and see what happens.

Thanks Again

m1.jpg

Share this post


Link to post
Share on other sites

I also added one for C:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe to “internet connection for programs”

Share this post


Link to post
Share on other sites

Looking at your settings I notice that mbam.exe is set for Outgoing, it should be set to Full so that it is not blocked at all. Please make sure that mbamservice.exe is set the same way (Full) and you should be fine assuming you've already set all the other exclusions, including excluding McAfee from Malwarebytes' Anti-Malware.

Share this post


Link to post
Share on other sites

Looking at your settings I notice that mbam.exe is set for Outgoing, it should be set to Full so that it is not blocked at all. Please make sure that mbamservice.exe is set the same way (Full) and you should be fine assuming you've already set all the other exclusions, including excluding McAfee from Malwarebytes' Anti-Malware.

Thanks for the help. Added full to both Malwarebyte entries, running a full McAfee scan now. I never run them both at the same time. The last McAfee scan attempt crashed, which never ever happened before but lets just hope that was a coincidence :(

err.jpg

I don’t doubt you for 1 second but, I’ve never added any exceptions to Malwarebyte OR McAfee and been running them for over a year, never a conflict that I saw. I’m a little confused; do I have to add a Malwarebyte exception for every .exe in the McAfee folders?

mce.jpg

Thanks for your help

Share this post


Link to post
Share on other sites

Just add the McAfee Program Files folder as described here. 2010 was quite different and generally didn't require any exclusions to be set, but 2011 does, the scan crashing is a known issue and should be resolved by adding C:\Program Files\McAfee to the Ignore List in Malwarebytes' Anti-Malware.

Share this post


Link to post
Share on other sites

Was able to run full Malwarebytes and McAfee scans, all looks good. Boy does it take McAfee a looooooong time to scan DVD images

Thanks for the Help

Share this post


Link to post
Share on other sites

You're welcome, I'm glad you got everything playing nicely together now :).

Please post again if you have any future issues or concerns.

Thanks :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.